カテゴリー別アーカイブ: アプリ

「Google Mobile Ads SDK をアップグレードしてください」の対応

スポンサーリンク

「Google Mobile Ads SDK をアップグレードしてください」というメールが来たので、その対応方法

「2018 年 1 月 23 日をもちまして、バージョン 7.0.0 より古い Google Mobile
Ads SDK は Android 版、iOS 版ともにサポート終了となります。」とのことで、該当しそうなのでアップグレードしました。

①build.gradleを開いて、SDKをとりあえず「compile ‘com.google.android.gms:play-services-ads:11.6.0’」に修正する。結果、エラーで、アプリが起動しなくなる

②アンドロイドスタジオ自体が2.0なので、この際だから、3.0にアップグレード。うまくすればそれだけで解決するかも?って思ったが、まったく変わらずエラー

③エラーのメッセージの指示通り、アップグレードを繰り返す。それでも、エラー

④「https://developers.google.com/admob/android/quick-start?hl=ja」で、グーグルさんが解説しているが、build.gradleを開いて、

maven {
            url "https://maven.google.com"
        }

を追記する。結果、エラー。

⑤エラーの内容が変わり、SDKがどうのこうのから、minSdkVersionが14以上じゃねえとダメだぞ的なことを英語で言っているので、マニフェストファイルを開いて、minSdkVersionのところを14にする。該当箇所は2箇所でした。結果、解決。

 アンドロイドスタジオはアップグレードの必要はないかもしれんが、グーグルさんのデベロッパーページに書いてあるとおり、build.gradleファイルを開いて、新たに?mavenなんたらを追記、compileを11.6.0に、minsdkを14以上にすれば解決するっぽい・・・

エラーの記載から、解説が英語なので、理解するのが大変・・・

スポンサーリンク